nixos-config/hardware/pilot1.nix

37 lines
776 B
Nix

{
config,
lib,
pkgs,
...
}:
{
boot.initrd.availableKernelModules = [
"xhci_pci"
"ahci"
"usbhid"
"usb_storage"
"sd_mod"
"rtsx_pci_sdmmc"
];
boot.initrd.kernelModules = [ "dm-snapshot" ];
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
fileSystems."/" = {
device = "/dev/disk/by-uuid/155b5acf-a0f8-4615-ae03-43a5c193f772";
fsType = "ext4";
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/31C7-CBD1";
fsType = "vfat";
};
swapDevices = [ { device = "/dev/disk/by-uuid/397a1a92-596f-421b-99e1-c9b2cb821309"; } ];
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}